Saturday, July 20, 2013

[Article] My ASRock Z68 Extreme4 motherboard having bios issues

With a lot of testing, I was able to finally find the settings that made the CPU overclock stable. It took a lot of work, to be honest, and I came across some weird issues with the BIOS of my ASRock Z68 Extreme4 motherboard during that testing.
The biggest issue was that the settings that I set in the bios being not saved when I told it to save and exit. I even misjudged it as a corrupted Windows installation once and almost reinstalled Windows. Luckily, I got a BSOD while booting into the setup and I knew something else was at work. I had set 4.8GHz in bios, which was not stable, and even when I set it to 4.7GHz, it remained at 4.8GHz. However, resetting the BIOS using the Clear CMOS button on the back panel worked.
Yesterday I was reading some forum posts about Haswell overclocking and I wanted to check how my CPU compared with the 4770K. When I ran Cinebench on my PC, I only managed to score 8.30 points. That's a pretty low score for a 2600K @4.5GHz. I ran it again and I got the same score. I felt something was not right, so this time I ran it with CPU-Z running by the side. I could see what was wrong. The CPU multiplier would drop to 44x and even 42x during the test.
So I went into bios and I found out that the settings had been reset to the defaults on the overclocking section! But I didn't understand how it ran at 45x multi in the first place because according to what was shown on bios, it should have run at 34x. Weird! What actually caused the multiplier to throttle was TDP limit which was reset to 95W.
So I loaded the overclocking profile I had saved for 4.5GHz and checked Cinebench again. This time I got a score of 8.72 which is about right.
Now, I wanted to play with the RAM timings because I was running them at SPD timings (i.e. 9/9/9/24 2T). I set it to 9/8/8/20 1T and booted back to Windows. When I checked the timings on CPU-Z, it still showed me the SPD timings. I tried several times to set the timings in bios but nothing worked. So I cleared CMOS settings again. The first time it booted to UEFI environment, it was unusable. The mouse movement wasn't smooth. The display was like a slide-show. It felt as if running Crysis 3 on decade old hardware. (But you cannot so that even if you want to because Crysis 3 needs DX11)
So I cleared the CMOS settings again. This time it worked and when I set the RAM timings as 9/8/8/20 1T, CPU-Z could see them. I don't know if those settings are stable though. I know for a fact that I cannot run these RAM at CL8.
Anyways, I don't know if the mobo is dying or if the cause was something else. I've seen some people say that pressing the Clear CMOS button alone is not enough; you need to remove the battery and put it back after few minutes. I will try that too. If it doesn't fix it, I will have to make a decision. I wonder if it has some warranty left. I've had the motherboard for 2 years now.

No comments:

Post a Comment

Related Posts Plugin for WordPress, Blogger...